<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>12 of the best current TV shows you can catch up to on Netflix, Business Insider - Business Insider Singapore</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.businessinsider.sg/xmlrpc.php" />
    <meta property="og:image" content="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png" /><meta name="author" content="<a target='_blank' href='http://www.businessinsider.com/author/carrie-wittmer/?IR=T'>Carrie Wittmer</a>, <a target='_blank' href='http://www.businessinsider.com/?IR=T'>Business Insider US</a>">
<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Business Insider Singapore &raquo; Feed" href="https://www.businessinsider.sg/feed/" />
<meta name="description"  content="Business Insider - We collected some of the best running shows that are available on Netflix now, so you can play catch-up before they return. You can watch shows like  'Riverdale,' 'Better Call Saul,' 'The Good Place,' and 'Jane the Virigin' on Netflix right now.. Read more at businessinsider.sg" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.businessinsider.sg\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.6"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bi-author-attribution-style-css'  href='https://www.businessinsider.sg/wp-content/plugins/businessinsider-author-attribution/css/style.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='bi-footerstyle-css'  href='https://www.businessinsider.sg/wp-content/plugins/businessinsider-footerstyle/css/bi-footer-style.css?ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-font-awesome-css'  href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://www.businessinsider.sg/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.6.4' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.businessinsider.sg/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='css-bi-header-12-css'  href='https://www.businessinsider.sg/wp-content/plugins/businessinsider-td-api-plugin/css/businessinsider-headerstyle.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Fanwood+Text%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=7.8' type='text/css' media='all' />
<link rel='stylesheet' id='ubermenu-css'  href='https://www.businessinsider.sg/wp-content/plugins/ubermenu/pro/assets/css/ubermenu.min.css?ver=3.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.businessinsider.sg/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.businessinsider.sg/wp-content/themes/Newspaper/style.css?ver=7.8' type='text/css' media='all' />
      <script>
      if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }
      </script>
      <script type='text/javascript' src='https://www.businessinsider.sg/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.6.4'></script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.6.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"100","ajax_url":"https:\/\/www.businessinsider.sg\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"1051549","token":"96f233764f"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/plugins/wordpress-popular-posts/public/js/tracking.js?ver=4.0.0'></script>
<!-- OG: 2.4.7 -->
<link rel="image_src" href="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png" />
<meta itemprop="image" content="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png" />
<meta name="msapplication-TileImage" content="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png" />

<meta property="og:image" content="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png" />
<meta property="og:description" content="We collected some of the best running shows that are available on Netflix now, so you can play catch-up before they return. You can watch shows like  &#039;Riverdale,&#039; &#039;Better Call Saul,&#039; &#039;The Good Place,&#039; and &#039;Jane the Virigin&#039; on Netflix right now." />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="Business Insider Singapore" />
<meta property="og:title" content="12 of the best current TV shows you can catch up to on Netflix" />
<meta property="og:url" content="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/" />
<meta property="article:tag" content="Features" />
<meta property="article:tag" content="Netflix" />
<meta property="article:tag" content="TV" />
<meta property="article:published_time" content="2018-06-05T18:24:01+00:00" />
<meta property="article:modified_time" content="2018-06-05T18:24:01+00:00" />
<meta property="article:author" content="https://www.businessinsider.sg/author/businessinsider/" />
<meta property="article:section" content="Life" />
<meta property="article:section" content="Tech Insider" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:title" content="12 of the best current TV shows you can catch up to on Netflix" />
<meta property="twitter:description" content="We collected some of the best running shows that are available on Netflix now, so you can play catch-up before they return. You can watch shows like  &#039;Riverdale,&#039; &#039;Better Call Saul,&#039; &#039;The Good Place,&#039; and &#039;Jane the Virigin&#039; on Netflix right now." />
<meta property="twitter:image" content="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png" />
<meta property="twitter:url" content="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/" />
<meta property="profile:first_name" content="Business Insider" />
<meta property="profile:username" content="&lt;a target=&#039;_blank&#039; href=&#039;http://www.businessinsider.com/author/carrie-wittmer/?IR=T&#039;&gt;Carrie Wittmer&lt;/a&gt;, &lt;a target=&#039;_blank&#039; href=&#039;http://www.businessinsider.com/?IR=T&#039;&gt;Business Insider US&lt;/a&gt;" />
<!-- /OG -->
<link rel='https://api.w.org/' href='https://www.businessinsider.sg/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.businessinsider.sg/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.businessinsider.sg/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='You can control this new software with your brain, and it should make Elon Musk and Mark Zuckerberg nervous' href='https://www.businessinsider.sg/brain-computer-interface-startup-nuro-could-beat-facebook-elon-musk-2018-4/' />
<link rel='next' title='Singapore Art Museum&#8217;s &#8216;Late Nights&#8217; returns to solve all your problems when it comes to Fri-date-night ideas' href='https://www.businessinsider.sg/singapore-art-museums-late-nights-returns-to-solve-all-your-problems-when-it-comes-to-fri-date-night-ideas/' />
<meta name="generator" content="WordPress 4.8.6" />
<link rel='shortlink' href='https://www.businessinsider.sg/?p=1051549' />
<link rel='canonical' href='https://www.businessinsider.com/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/' />
<meta name="google-site-verification" content="oTsGDXaLu-_3kOQv9c9vMzq-x2pwUeN2QxBzCZ15Dw0" /><style>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</style>

<style>
#the_mediaoutreach_content p{
    margin-bottom:0;
}
</style>

<!-- SMX Implementation -->
<script>
var lb_sizes = '970x90,728x90,970x250,728x90,320x50,320x50';

var loaded_dfp_tags = {};

loaded_dfp_tags.lb1 = {
    'adunit': '5908/BI_SG/lb1/life',
    'slotname' : 'dfp-ad-lb1',
    'size' : lb_sizes
};
loaded_dfp_tags.imu2 = {
    'adunit': '/5908/BI_SG/imu2/life',
    'slotname' : 'dfp-ad-imu2',
    'size' : '300x250,300x600'
};
loaded_dfp_tags.topoverlay = {
    'adunit': '/5908/BI_SG/topoverlay/life',
    'slotname' : 'dfp-ad-topoverlay',
    'size' : '1x1'
};
</script>


<script>
    loaded_dfp_tags.midarticlespecial = {
        'adunit': '/5908/BI_SG/midarticlespecial/life',
        'slotname' : 'dfp-ad-midarticlespecial',
        'size' : '1x1,fluid'
    };
</script>



<!-- GRAPESHOT channel tag -->
<script type="text/javascript">
var isArticlePage = 1;

if(isArticlePage) {
var gs_channels="no_category";
var gsurl=window.location!=window.top.location?document.referrer:window.location;
document.write('<scr'+'ipt type="text/javascript" src="//sph.gscontxt.net/main/channels.cgi?url='+encodeURIComponent(gsurl)+'"></scr'+'ipt>');
}
</script>
<!-- GRAPESHOT channel tag END -->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NX4342R');</script>
<!-- End Google Tag Manager -->

<script async src='//www.googletagservices.com/tag/js/gpt.js'></script>
<!-- Prebid : Start -->
<script src="//adtag.sphdigital.com/tag/businessinsider/js/prebid/sg/prebid.js"></script>
<script src="//adtag.sphdigital.com/tag/businessinsider/js/prebid/sg/prebid_bisg.js"></script>
<!-- Prebid : End -->

<!-- Google Tag Manager US -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MTGK9G');</script>
<!-- End Google Tag Manager US -->
<!-- Begin Preview/Referrer Script -->
<script type="text/javascript">
  
  //Begin Preview
  function querystring(key) {
     var re=new RegExp('(?:\\?|&)'+key+'=(.*?)(?=&|$)','gi');
     var r=[], m;
     while ((m=re.exec(document.location.search)) != null) r[r.length]=m[1];
     return r;
  }
  var key ='dfp_preview';
  var keycode = querystring(key);
  //End Preview
  
  //Begin referrer
  function getreferrer() {
		var refresponse = "direct";
		var siteref = "";
		if (document.referrer.split("/")[2]) {
			siteref = document.referrer.split("/")[2];
			if (/google/i.test(siteref)) {
				refresponse = "google";
			} else if (/facebook/i.test(siteref)) {
				refresponse = "facebook";
			} else {
				refresponse = "others";
			}
		}
		return refresponse;
	}
	var tarref = getreferrer();
  //End referrer
  </script>
<!-- End Preview/Referrer Script -->  
<!-- Begin Lotame ID -->
<script src="//tags.crwdcntrl.net/c/11081/cc_af.js"></script>
<script type="text/javascript" src="//ad.crwdcntrl.net/5/c=4334/pe=y/var=ccauds">
  </script>
<script type="text/javascript">
if (typeof(ccauds) !== "undefined") {
      var lotameid = ccauds.Profile.pid;
    }else{
      var lotameid = '';
    }
</script>
<!-- End Lotame ID -->

<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
   var mapping = googletag.sizeMapping()
  .addSize([1024, 0], [[970, 90], [728, 90], [970, 250]])
  .addSize([740, 0], [728, 90])
  .addSize([480, 0], [320, 50])
  .addSize([0, 0], [320, 50])
  .build();
googletag.defineSlot("/5908/BI_SG/lb1/life", [728, 90], "dfp-ad-lb1")
  .addService(googletag.pubads()).setTargeting("bisgtags", ["features","netflix","tv"]).setTargeting("bisgarticleid", "1051549").setTargeting(key, keycode).defineSizeMapping(mapping);
googletag.defineSlot("/5908/BI_SG/imu1/life", [[300, 250], "fluid"],"dfp-ad-imu1")
  .addService(googletag.pubads()).setTargeting("bisgtags", ["features","netflix","tv"]).setTargeting("bisgarticleid", "1051549").setTargeting(key, keycode);
googletag.defineSlot("/5908/BI_SG/imu2/life", [[300, 250], [300, 600]],"dfp-ad-imu2")
  .addService(googletag.pubads()).setTargeting("bisgtags", ["features","netflix","tv"]).setTargeting("bisgarticleid", "1051549").setTargeting(key, keycode);
googletag.defineSlot("/5908/BI_SG/topoverlay/life", [1, 1],"dfp-ad-topoverlay")
  .addService(googletag.pubads()).setTargeting("bisgtags", ["features","netflix","tv"]).setTargeting("bisgarticleid", "1051549").setTargeting(key, keycode).setTargeting("referrer", tarref);
googletag.defineSlot("/5908/BI_SG/midarticlespecial/life", [[1, 1],"fluid"],"dfp-ad-midarticlespecial")
  .addService(googletag.pubads()).setTargeting("bisgtags", ["features","netflix","tv"]).setTargeting("bisgarticleid", "1051549").setTargeting(key, keycode);


googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().collapseEmptyDivs();
});

    if(isArticlePage) {
       googletag.pubads().setTargeting('gs_channels', gs_channels);
       var gsMetaTag = document.createElement('meta');
       gsMetaTag.id = 'grapeshot';
       gsMetaTag.name = 'grapeshot_tag';
       gsMetaTag.content = gs_channels;
       document.getElementsByTagName('head')[0].appendChild(gsMetaTag);
    }

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
	
    googletag.cmd.push(function() {
    googletag.pubads().setTargeting('dfp_cc_id', window.lotameid);
});

  });
</script>
<style id="ubermenu-custom-generated-css">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</style><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.businessinsider.sg/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/amp/" /><meta name="generator" content="Powered by Slider Revolution 5.4.6.4 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var tds_general_modal_image="yes";
var td_ajax_url="https:\/\/www.businessinsider.sg\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.8";
var td_get_template_directory_uri="https:\/\/www.businessinsider.sg\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="13";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=700;
var tds_theme_color_site_wide="#185f7d";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<link rel="icon" href="https://static.businessinsider.sg/sites/2/2018/03/cropped-BI-favicon-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://static.businessinsider.sg/sites/2/2018/03/cropped-BI-favicon-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://static.businessinsider.sg/sites/2/2018/03/cropped-BI-favicon-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://static.businessinsider.sg/sites/2/2018/03/cropped-BI-favicon-270x270.jpg" />
<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-1051549 single-format-standard best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6 global-block-template-12 single_template_14 wpb-js-composer js-comp-ver-5.4.5 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.facebook.com/businessinsider" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company-beta/13353323/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/businessinsider" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-42907" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom menu-item-first td-no-down-arrow menu-item-42907"><a href="#ubermenu-custom_content">[Custom]</a></li>
<li id="menu-item-43078" class="bi_nav_trending menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-43078"><a href="https://www.businessinsider.sg/trending/">Trending<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-43079" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-43079"><a href="#ubermenu-custom_content">[Custom]</a></li>
</ul>
</li>
<li id="menu-item-43080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-43080"><a href="https://www.businessinsider.sg/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-43081" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-43081"><a href="#ubermenu-dynamic_posts">[Dynamic Posts]</a></li>
</ul>
</li>
<li id="menu-item-44070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-44070"><a href="https://www.businessinsider.sg/tech-insider/">Tech Insider<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-44071" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-44071"><a href="#ubermenu-dynamic_posts">[Dynamic Posts]</a></li>
</ul>
</li>
<li id="menu-item-44072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-44072"><a href="https://www.businessinsider.sg/finance/">Finance<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-44073" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-44073"><a href="#ubermenu-dynamic_posts">[Dynamic Posts]</a></li>
</ul>
</li>
<li id="menu-item-44074" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-44074"><a href="https://www.businessinsider.sg/career/">Career<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-44075" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-44075"><a href="#ubermenu-dynamic_posts">[Dynamic Posts]</a></li>
</ul>
</li>
<li id="menu-item-44407" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-44407"><a href="https://www.businessinsider.sg/life/">Life<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-44408" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-44408"><a href="#ubermenu-dynamic_posts">[Dynamic Posts]</a></li>
</ul>
</li>
<li id="menu-item-44409" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-44409"><a href="https://www.businessinsider.sg/video/">Video<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-44410" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-44410"><a href="#ubermenu-dynamic_posts">[Dynamic Posts]</a></li>
</ul>
</li>
<li id="menu-item-44411" class="menu-item menu-item-type-custom menu-item-object-ubermenu-custom td-no-down-arrow menu-item-44411"><a href="#ubermenu-custom_content">[Custom]</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.businessinsider.sg/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 3
-->

<div class="td-header-wrap td-header-style-13">

    

    <div class="td-banner-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-logo">
                            </div>            
        </div>
		
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-42896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-42896"><a href="http://intelligence.businessinsider.com/?utm_source=businessinsider&#038;utm_medium=site_header&#038;utm_term=bi_site_header&#038;utm_content=bi_site_header&#038;utm_campaign=bi_site_header&#038;IR=C">BI Intelligence</a></li>
<li id="menu-item-42897" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42897"><a href="http://www.businessinsider.com/events/?IR=C">Events</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.facebook.com/businessinsider" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.linkedin.com/company-beta/13353323/" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/businessinsider" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->
			<div class="editionDD">
				<div class="bi-user-edition">
					<a href="" class="label">Edition <i class="icon-down-open">&#xe800;</i></a>
					<ul class="dropdown-menu popover bottom">
						<div class="arrow"></div>
						<li>
							<h4 class="">Choose Edition:</h4>
							<div class="list-group"> 
								<a href="https://www.businessinsider.sg/" class="active">Singapore</a>
								<a href="http://www.businessinsider.my/">Malaysia</a>        
								<a href="http://www.businessinsider.com?IR=C">United States</a>
								<a href="http://uk.businessinsider.com?IR=C">United Kingdom</a>                
								<a href="http://www.businessinsider.de?IR=C">Deutschland</a>
								<a href="http://www.businessinsider.com.au/">Australia</a>
								<a href="http://www.businessinsider.in/">India</a>   
								<a href="http://www.businessinsider.com.pl/?IR=C">Poland</a>  
								<a href="http://nordic.businessinsider.com/?IR=C">Nordic</a> 
								<a href="http://www.businessinsider.nl?IR=C">Netherlands</a>  
								<a href="http://www.businessinsider.fr/?IR=C">France</a>
								<a href="https://it.businessinsider.com">Italy</a>
								<a href="http://www.businessinsider.jp">Japan</a>
								<a href="https://www.businessinsider.es">España</a>
								<a href="https://www.businessinsider.co.za">South Africa</a>
							</div>        
						</li>
					</ul>
				</div>
			</div>
			<script src="https://www.businessinsider.sg/wp-content/plugins/businessinsider-td-api-plugin/template/../js/site-selector.js?position=right&amp;edition=us"></script>
        </div>
    
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap td_stretch_container">
        <div class="td-header-menu-wrap">
            <div class="td-container td-header-row td-header-main-menu black-menu">
				<div class="topmenu-search">
					<button id="searchbtn">
					</button>
				</div>
				
<!-- UberMenu [Configuration:main] [Theme Loc:header-menu] [Integration:api] -->
<a class="ubermenu-responsive-toggle ubermenu-responsive-toggle-main ubermenu-skin-none ubermenu-loc-header-menu ubermenu-responsive-toggle-content-align-center ubermenu-responsive-toggle-align-left ubermenu-responsive-toggle-icon-only " data-ubermenu-target="ubermenu-main-6661-header-menu-2"><i class="fa fa-bars"></i></a><nav id="ubermenu-main-6661-header-menu-2" class="ubermenu ubermenu-nojs ubermenu-main ubermenu-menu-6661 ubermenu-loc-header-menu ubermenu-responsive ubermenu-responsive-single-column ubermenu-responsive-767 ubermenu-responsive-collapse ubermenu-horizontal ubermenu-transition-slide ubermenu-trigger-hover_intent ubermenu-skin-none  ubermenu-bar-align-full ubermenu-items-align-center ubermenu-retractors-responsive"><ul id="ubermenu-nav-main-6661-header-menu" class="ubermenu-nav"><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-item-first ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-42907 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded sticky-logo-wrap"><div class="sticky-logo"></div></div></li><li class="bi_nav_trending ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43078 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/trending/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Trending</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-43078 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43079 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-auto" ><div class="ubermenu-content-block ubermenu-custom-content ubermenu-custom-content-padded bi_nav_trending">
<!-- WordPress Popular Posts Plugin v4.0.0 [PHP] [daily] [views] [custom] -->

<ul class="wpp-list">
<li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-776 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4 bipopularposts"><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-content-align-center ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/ios-12-changes-updates-new-features-apple-wwdc-2018-6/"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/1049207-featured-324x235.png" width="324" height="235" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /><span class="ubermenu-target-title ubermenu-target-text bipoptitle">Apple just announced iOS 12. Here are all the major changes coming to iPhones and iPads.</span></a></li>
<li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-776 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4 bipopularposts"><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-content-align-center ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/mentally-strong-people-2015-11/"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/55984-featured-324x235.jpg" width="324" height="235" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /><span class="ubermenu-target-title ubermenu-target-text bipoptitle">13 things mentally strong people don&#8217;t do</span></a></li>
<li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-776 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4 bipopularposts"><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-content-align-center ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/lebron-james-pass-nba-finals-2018-6/"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/1045776-featured-324x235.jpg" width="324" height="235" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /><span class="ubermenu-target-title ubermenu-target-text bipoptitle">LeBron James threw an underappreciated all-world pass, and it sums up the Cavs&#8217; bleak outlook in the Finals</span></a></li>
<li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-776 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4 bipopularposts"><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-content-align-center ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/death-of-the-smartphone-and-what-comes-after-2017-3/"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/286274-featured-324x235.jpg" width="324" height="235" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /><span class="ubermenu-target-title ubermenu-target-text bipoptitle">The smartphone is eventually going to die, and then things are going to get really crazy</span></a></li>

</ul>

<!-- End WordPress Popular Posts Plugin v4.0.0 -->

<style>
.wpp-list li.ubermenu-item {
    width: 25% !important;
    text-align: left !important;
}
.wpp-list li.bipopularposts a.ubermenu-target {
    border: 0px !important;
}
.ubermenu .ubermenu-submenu .ubermenu-column {
    display: block;
    float: left;
}
.wpp-list li.bipopularposts > a img{
	border:0px; margin:0px;
}
.wpp-list .ubermenu-target-text{padding-top:0px;}
li.bi_nav_trending ul.ubermenu-submenu>li.ubermenu-item .ubermenu-content-block{padding-bottom:0px !important;padding-right:0px !important;padding-left:0px !important;}
.wpp-list li.bipopularposts{clear:none;}
li.bi_nav_trending ul.ubermenu-submenu>li.ubermenu-item{width:100% !important;}
.bipopularposts{margin-bottom:0px !important;}
.bipopularposts a{padding:15px 0px !important;}
.ubermenu-custom-content-padded{padding-top:0px !important;}
.bipoptitle{bottom:0px !important;}
</style>
<script type="text/javascript">
jQuery('li.bipopularposts a img').addClass("ubermenu-image ubermenu-image-size-td_356x220");
</script></div></li></ul></li><li class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43080 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/news/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">News</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-43080 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[43081] count[4] --><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43081 ubermenu-item-43081-post-1049845 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/watch-the-world-cup-for-free-at-55-locations-across-singapore-community-clubs-to-host-screenings/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/world-cup-cc-356x220.jpg" width="356" height="220" alt="world cup cc"  /><span class="ubermenu-target-title ubermenu-target-text">Watch the World Cup for free at 55 locations across Singapore, community clubs to host screenings</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43081 ubermenu-item-43081-post-1051513 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/justin-timberlake-debuts-bai-braspberry-supertea-flavor-2018-6/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b16cc101ae6623b008b4d9b-356x220.png" width="356" height="220" alt="Justin Timberlake now has his own Bai flavor."  /><span class="ubermenu-target-title ubermenu-target-text">Justin Timberlake has created his own new drink for a brand that&#8217;s becoming a threat to Coke and Pepsi</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43081 ubermenu-item-43081-post-1049792 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/najib-wife-rosmah-mansor-leaves-anti-graft-agency-headquarters-5-hours-interrogation/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/Rosmah-Mansor-Malaysian-Anti-Corruption-Commission-The-Straits-Times-2-356x220.jpg" width="356" height="220" alt="Rosmah Mansor Malaysian Anti-Corruption Commission The Straits Times (2)"  /><span class="ubermenu-target-title ubermenu-target-text">Former Malaysian PM Najib&#8217;s wife Rosmah Mansor leaves anti-graft agency headquarters after 5 hours of interrogation</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-43081 ubermenu-item-43081-post-1049804 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/singapore-art-museums-late-nights-returns-to-solve-all-your-problems-when-it-comes-to-fri-date-night-ideas/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/Sam-Late-nights-356x220.jpg" width="356" height="220" alt="Sam Late nights"  /><span class="ubermenu-target-title ubermenu-target-text">Singapore Art Museum&#8217;s &#8216;Late Nights&#8217; returns to solve all your problems when it comes to Fri-date-night ideas</span></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[43081] --></ul></li><li class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44070 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/tech-insider/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Tech Insider</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-44070 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[44071] count[4] --><li class="ubermenu-current-menu-item ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44071 ubermenu-item-44071-post-1051549 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2-356x220.png" width="356" height="220" alt="5b16b73a1ae6621a008b48f2"  /><span class="ubermenu-target-title ubermenu-target-text">12 of the best current TV shows you can catch up to on Netflix</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44071 ubermenu-item-44071-post-1020842 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/brain-computer-interface-startup-nuro-could-beat-facebook-elon-musk-2018-4/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b06e0841ae6621f008b4636-356x220.png" width="356" height="220" alt="5b06e0841ae6621f008b4636"  /><span class="ubermenu-target-title ubermenu-target-text">You can control this new software with your brain, and it should make Elon Musk and Mark Zuckerberg nervous</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44071 ubermenu-item-44071-post-1050158 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/oldest-lizard-fossil-sheds-light-on-reptile-evolution-2018-6/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b168cf91ae6621a008b4c58-356x220.jpg" width="356" height="220" alt="A life scene in the Dolomites region, Northern Italy, about 240 million years ago, with Megachirella wachtleri walking through the vegetation."  /><span class="ubermenu-target-title ubermenu-target-text">A 240-million-year-old fossil is now the oldest known ancestor of snakes and lizards &#8212; and experts are calling it a &#8216;Rosetta Stone&#8217; of evolution</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44071 ubermenu-item-44071-post-1049681 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/ocbc-bank-singapores-first-digital-account-opening-service-new-5-minutes/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/Instant-account-opening-OCBC-Bank-356x220.jpg" width="356" height="220" alt="Instant account opening OCBC Bank"  /><span class="ubermenu-target-title ubermenu-target-text">OCBC Bank launches Singapore&#8217;s first digital account-opening service that lets you set up a new bank account in 5 minutes</span></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[44071] --></ul></li><li class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44072 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/finance/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Finance</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-44072 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[44073] count[4] --><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44073 ubermenu-item-44073-post-1020842 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/brain-computer-interface-startup-nuro-could-beat-facebook-elon-musk-2018-4/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b06e0841ae6621f008b4636-356x220.png" width="356" height="220" alt="5b06e0841ae6621f008b4636"  /><span class="ubermenu-target-title ubermenu-target-text">You can control this new software with your brain, and it should make Elon Musk and Mark Zuckerberg nervous</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44073 ubermenu-item-44073-post-1049681 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/ocbc-bank-singapores-first-digital-account-opening-service-new-5-minutes/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/Instant-account-opening-OCBC-Bank-356x220.jpg" width="356" height="220" alt="Instant account opening OCBC Bank"  /><span class="ubermenu-target-title ubermenu-target-text">OCBC Bank launches Singapore&#8217;s first digital account-opening service that lets you set up a new bank account in 5 minutes</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44073 ubermenu-item-44073-post-283551 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/money-advice-you-shouldnt-ignore-2017-3/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b16c9821ae6623e008b4cdf-356x220.png" width="356" height="220" alt="Ignore these money tips and you&#039;ll regret it."  /><span class="ubermenu-target-title ubermenu-target-text">13 pieces of money advice you can&#8217;t afford to ignore</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44073 ubermenu-item-44073-post-1051048 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/under-armour-jobs-internship-program-2018-5/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b11b41f1ae6621e008b4a52-356x220.png" width="356" height="220" alt="Interns get 50% off Under Armour gear."  /><span class="ubermenu-target-title ubermenu-target-text">Inside Under Armour&#8217;s exclusive internship program, which is harder to get into than Harvard</span></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[44073] --></ul></li><li class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44074 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/career/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Career</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-44074 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[44075] count[4] --><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44075 ubermenu-item-44075-post-1051048 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/under-armour-jobs-internship-program-2018-5/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b11b41f1ae6621e008b4a52-356x220.png" width="356" height="220" alt="Interns get 50% off Under Armour gear."  /><span class="ubermenu-target-title ubermenu-target-text">Inside Under Armour&#8217;s exclusive internship program, which is harder to get into than Harvard</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44075 ubermenu-item-44075-post-865493 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/san-francisco-housing-so-expensive-people-leaving-2018-4/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5ac560ebf41c7819008b45f6-356x220.jpg" width="356" height="220" alt="People are leaving San Francisco because the rent, as they say, is too damn high."  /><span class="ubermenu-target-title ubermenu-target-text">The San Francisco housing market is so dire that people are leaving in droves &#8212;&#160;here&#8217;s where they&#8217;re headed</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44075 ubermenu-item-44075-post-785027 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/san-francisco-bay-area-residents-moving-away-increase-u-haul-rental-prices-2018-3/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5a9d8effed1ed818008b45bb-356x220.png" width="356" height="220" alt="5a9d8effed1ed818008b45bb"  /><span class="ubermenu-target-title ubermenu-target-text">San Francisco is losing more residents than any other city in the US, creating a shortage of U-Hauls that puts a rental at $2,000 just to move to Las Vegas</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44075 ubermenu-item-44075-post-1049084 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/megyn-kelly-oprah-winfrey-successful-people-30s-2018-6/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b1564731ae6621d008b487a-356x220.png" width="356" height="220" alt="Megyn Kelly didn&#039;t get her breakout job until she was 39."  /><span class="ubermenu-target-title ubermenu-target-text">9 incredibly successful people who made their careers in their 30s</span></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[44075] --></ul></li><li class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44407 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/life/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Life</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-44407 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[44408] count[4] --><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44408 ubermenu-item-44408-post-1049845 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/watch-the-world-cup-for-free-at-55-locations-across-singapore-community-clubs-to-host-screenings/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/world-cup-cc-356x220.jpg" width="356" height="220" alt="world cup cc"  /><span class="ubermenu-target-title ubermenu-target-text">Watch the World Cup for free at 55 locations across Singapore, community clubs to host screenings</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44408 ubermenu-item-44408-post-1051513 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/justin-timberlake-debuts-bai-braspberry-supertea-flavor-2018-6/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b16cc101ae6623b008b4d9b-356x220.png" width="356" height="220" alt="Justin Timberlake now has his own Bai flavor."  /><span class="ubermenu-target-title ubermenu-target-text">Justin Timberlake has created his own new drink for a brand that&#8217;s becoming a threat to Coke and Pepsi</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44408 ubermenu-item-44408-post-1049804 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/singapore-art-museums-late-nights-returns-to-solve-all-your-problems-when-it-comes-to-fri-date-night-ideas/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/Sam-Late-nights-356x220.jpg" width="356" height="220" alt="Sam Late nights"  /><span class="ubermenu-target-title ubermenu-target-text">Singapore Art Museum&#8217;s &#8216;Late Nights&#8217; returns to solve all your problems when it comes to Fri-date-night ideas</span></a></li><li class="ubermenu-current-menu-item ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44408 ubermenu-item-44408-post-1051549 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2-356x220.png" width="356" height="220" alt="5b16b73a1ae6621a008b48f2"  /><span class="ubermenu-target-title ubermenu-target-text">12 of the best current TV shows you can catch up to on Netflix</span></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[44408] --></ul></li><li class="ubermenu-item ubermenu-item-type-post_type ubermenu-item-object-page ubermenu-item-has-children ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44409 ubermenu-item-level-0 ubermenu-column ubermenu-column-auto ubermenu-has-submenu-drop ubermenu-has-submenu-mega" ><a class="ubermenu-target ubermenu-item-layout-default ubermenu-item-layout-text_only" href="https://www.businessinsider.sg/video/" tabindex="0"><span class="ubermenu-target-title ubermenu-target-text">Video</span></a><ul class="ubermenu-submenu ubermenu-submenu-id-44409 ubermenu-submenu-type-auto ubermenu-submenu-type-mega ubermenu-submenu-drop ubermenu-submenu-align-full_width" ><!-- begin Dynamic Posts: [Dynamic Posts] ID[44410] count[4] --><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44410 ubermenu-item-44410-post-995504 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/what-happens-inside-automated-parking-garage-2018-4/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/05/heres-what-really-happens-to-your-car-when-you-use-an-automated-parking-garage-356x220.jpg" width="356" height="220" alt="heres-what-really-happens-to-your-car-when-you-use-an-automated-parking-garage"  /><span class="ubermenu-target-title ubermenu-target-text">Here&#8217;s what really happens to your car when you use an automated parking garage</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44410 ubermenu-item-44410-post-962729 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/google-duplex-home-assistant-full-conversations-make-appointments-reservations-2018-5/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/05/googles-new-ai-can-impersonate-a-human-to-schedule-appointments-and-make-reservations-356x220.jpg" width="356" height="220" alt="googles-new-ai-can-impersonate-a-human-to-schedule-appointments-and-make-reservations"  /><span class="ubermenu-target-title ubermenu-target-text">Google&#8217;s new AI can impersonate a human to schedule appointments and make reservations</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44410 ubermenu-item-44410-post-962727 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/why-cockroaches-are-hard-to-kill-pest-control-2018-4/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/05/why-cockroaches-are-so-hard-to-kill-356x220.jpg" width="356" height="220" alt="why-cockroaches-are-so-hard-to-kill"  /><span class="ubermenu-target-title ubermenu-target-text">Why cockroaches are so hard to kill</span></a></li><li class="ubermenu-item ubermenu-item-type-custom ubermenu-item-object-ubermenu-custom ubermenu-td-no-down-arrow ubermenu-td-menu-item ubermenu-td-normal-menu ubermenu-item-44410 ubermenu-item-44410-post-916060 ubermenu-item-auto ubermenu-item-header ubermenu-item-level-1 ubermenu-column ubermenu-column-1-4" ><a class="ubermenu-target ubermenu-target-with-image ubermenu-item-layout-default ubermenu-item-layout-image_above" href="https://www.businessinsider.sg/tech-addiction-teens-break-bone-lose-iphone-2018-4/"><img class="ubermenu-image ubermenu-image-size-td_356x220" src="https://static.businessinsider.sg/sites/2/2018/04/teens-would-rather-break-their-bones-than-lose-their-phones-356x220.jpg" width="356" height="220" alt="teens-would-rather-break-their-bones-than-lose-their-phones"  /><span class="ubermenu-target-title ubermenu-target-text">Teens would rather break their bones than lose their phones</span></a></li><!-- end Dynamic Posts: [Dynamic Posts] ID[44410] --></ul></li></ul></nav>
<!-- End UberMenu -->
                		
				<div class="search-box">
					<form class="search-field" method="get" action="https://www.businessinsider.sg/">
							<input data-search-input="" type="text" value="" name="s" autocomplete="off" placeholder="Search" >
					 </form>
				</div>
	
				
            </div>
        </div>
    </div>
	
	<div class="td-banner-wrap-full td-container-wrap head-adv ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  "> <div align="center" class="leaderboard">
<!-- /5908/BI_SG/lb1/bi/sg -->
<div id='dfp-ad-lb1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('dfp-ad-lb1'); });
</script>
</div>
</div></div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span class="td-bred-first"><a href="https://www.businessinsider.sg/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
                               <a title="View all posts in Life" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="https://www.businessinsider.sg/category/life/">
                                  <span itemprop="name">Life</span>    </a>    <meta itemprop="position" content = "1"></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">12 of the bes...</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-1051549" class="post-1051549 post type-post status-publish format-standard has-post-thumbnail hentry category-life category-tech tag-features tag-netflix tag-tv" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">12 of the best current TV shows you can catch up to on Netflix</h1>

                

                <div class="td-module-author-avtar">
                                    </div>
                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.businessinsider.sg/author/businessinsider/"><a target='_blank' href='http://www.businessinsider.com/author/carrie-wittmer/?IR=T'>Carrie Wittmer</a>, <a target='_blank' href='http://www.businessinsider.com/?IR=T'>Business Insider US</a></a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-05T18:24:01+00:00" >June 5, 2018</time></span>                                                        </div>

            </header>

        </div>

        

        <div class="td-post-content">

        
        <!-- Go to www.addthis.com/dashboard to customize your tools --> 
<div class="addthis_inline_share_toolbox" data-url="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/"></div><div id="the_bi_content">
<div >      <img  src="https://static.businessinsider.sg/2018/06/06/5b16b73a1ae6621a008b48f2.png" class="bi_image size-medium wp-image-1051559" bisrc="https://static.businessinsider.com/image/5b16b73a1ae6621a008b48f2.png"/>      </p>
<dl >
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5b16b73a1ae6621a008b48f2">AMC</dd>
</dl>
<p >Still  behind on the biggest and best TV shows?</p>
<p >  Thankfully it&#8217;s almost summer, which means you might have some  free time or vacation days to squeeze in a lot of binge-watching  of the currently running shows that you&#8217;ve missed.</p>
<p >  For years, Netflix has been a prime source for this &#8211; so much so  that some TV shows experience what is known as the &#8220;Netflix  Effect.&#8221;</p><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<div align="center" class="iframeholder">
<!-- /5908/BI_SG/imu1/bi/sg -->
<div id='dfp-ad-imu1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('dfp-ad-imu1'); });
</script>
</div>
</div></div>

<p >  Once a series is available on Netflix, it&#8217;s easier for more  people to catch up. This can spur a rise in popularity. Shows  that saw their popularity soar once they became available on  Netflix famously <a href="https://variety.com/2013/digital/news/netflix-flexes-new-muscle-with-breaking-bad-ratings-boom-1200577029/">  include</a> AMC&#8217;s &#8220;Breaking Bad&#8221; and The CW&#8217;s &#8220;Riverdale&#8221; (which  gained in popularity last summer when it became available on  Netflix in between seasons one and two). This also happened when  NBC&#8217;s &#8220;The Good Place&#8221; came to the streaming service last fall, a  few weeks before season two premiered. </p>
<p >  Here, we collected some of the best running shows that are  available on Netflix now, so you can play catch-up before they  return.</p>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; clear: both;'>
<div align="center" class="iframeholder">
<!-- /5908/BI_SG/midarticlespecial/bi/sg -->
<div id="innity-in-post"></div>
<div id='dfp-ad-midarticlespecial'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('dfp-ad-midarticlespecial'); });
</script>
</div>
</div></div>
<p >        <strong>From &#8220;The Good Place&#8221; to &#8220;Riverdale,&#8221; here&#8217;s some of the  best shows on TV that you can watch on Netflix right now.  </strong>      </p>
<hr />
<h3 >&#8220;The Good Place&#8221; &mdash; NBC, one season available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/59c56ce42488494dd80ccc03.png" id="image-59c56ce42488494dd80ccc03" class="bi_image size-medium wp-image-1051558" bisrc="https://static.businessinsider.com/image/59c56ce42488494dd80ccc03.png"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-59c56ce42488494dd80ccc03">Colleen Hayes/NBC</dd>
</dl>
<p ><strong>Netflix description: </strong>Due to an error,  self-absorbed Eleanor Shellstrop arrives at the Good Place after  her death. Determined to stay, she tries to become a better  person.</p>
<p ><strong>Critic score:</strong> 95%</p>
<p ><strong>Audience score:</strong> 87%</p>
<p >  The heavenly, whip-smart comedy starring Kristen Bell and Ted  Danson is unlike anything else on TV. The season one and two  finales end with shocking twists that both set a completely new  premise for the next season.</p>
<p >  Expect season three of &#8220;The Good Place&#8221; in the fall. Season two  should become available on Netflix shortly before that premieres.  </p>
<hr />
<h3 >&#8220;Riverdale&#8221; &mdash; The CW, two seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2017/12/12/5a30146e8229f21e008b4be7.jpg" id="image-5a30146e8229f21e008b4be7" class="bi_image size-medium wp-image-465808" bisrc="https://static.businessinsider.com/image/5a30146e8229f21e008b4be7.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5a30146e8229f21e008b4be7">The CW</dd>
</dl>
<p ><strong>Netflix description: </strong>While navigating the  troubled waters of sex, romance, school and family, teen Archie  and his gang become entangled in a dark Riverdale mystery.</p>
<p ><strong>Critic score:</strong> 87%</p>
<p >        <strong>Audience score: 77%</strong>      </p>
<p >  If you&#8217;re into glossy, cheesy teen drama that doesn&#8217;t require  much brain power (where the teens are played by adults well into  their 20s), The CW&#8217;s &#8220;Riverdale&#8221; is perfect for a summer  binge-watch. The characters are based on the Archie comics  (Archie, Betty, Veronica, and many more) but they&#8217;re in a modern  setting, with lots of murder. Seriously. There is so much murder  on this show, especially in its bloody second season.</p>
<p >  Expect season three of &#8220;Riverdale&#8221; in the fall. </p>
<hr />
<h3 >&#8220;Shameless&#8221; &mdash; Showtime, seven seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/57c98544dd0895c9368b4ca0.jpg" id="image-57c98544dd0895c9368b4ca0" class="bi_image size-medium wp-image-1051557" bisrc="https://static.businessinsider.com/image/57c98544dd0895c9368b4ca0.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-57c98544dd0895c9368b4ca0">Showtime/Warren Feldman</dd>
</dl>
<p ><strong>Netflix description: </strong>This dramedy based on a  British series centers on siblings in a dysfunctional Chicago  family who struggle while coping with their alcoholic father.</p>
<p ><strong>Critic score:</strong> 93%</p>
<p ><strong>Audience score:</strong> 88%</p>
<p >  &#8220;Shameless&#8221; is an unconventional family drama and dark comedy  that comes with incredible performances, and a lot of shocking  twists and turns for its messy but lovable characters. </p>
<p >  Season eight should be available on Netflix soon, and you can  expect season nine to premiere in late 2018 or early 2019. </p>
<hr />
<h3 >&#8220;Crazy Ex-Girlfriend&#8221; &mdash; The CW, three seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/579bb329dd08957b3d8b4577.jpg" id="image-579bb329dd08957b3d8b4577" class="bi_image size-medium wp-image-1051556" bisrc="https://static.businessinsider.com/image/579bb329dd08957b3d8b4577.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-579bb329dd08957b3d8b4577">Eddy Chen/The CW</dd>
</dl>
<p ><strong>Netflix description: </strong>Still pining for Josh, the  boy who dumped her ages ago, whip-smart lawyer Rebecca jettisons  her New York life and moves to California to win him back.</p>
<p ><strong>Critic score:</strong> 97%</p>
<p ><strong>Audience score:</strong> 87%</p>
<p >  While &#8220;Crazy Ex-Girlfriend&#8221; certainly isn&#8217;t the first TV show to  cover mental illness, it is the first to approach it in such a  deeply personal, vulnerable way. And while this all sounds very  sad, the show and its original songs (usually one to three per  episode) keep the show&#8217;s quirky and hilarious roots present. It&#8217;s  an excellent, non-judgmental (and very funny) examination of  deeply flawed adults as they become more self-aware of their best  and worst qualities. </p>
<p >  Expect season four of &#8220;Crazy-Ex Girlfriend&#8221; (its final season) in  the fall.    </p>
<hr />
<h3 >&#8220;Being Mary Jane&#8221; &mdash; BET, four seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/03/03/5a2563b3f914c35a018b7a2b.jpg" id="image-5a2563b3f914c35a018b7a2b" class="bi_image size-medium wp-image-551526" bisrc="https://static.businessinsider.com/image/5a2563b3f914c35a018b7a2b.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5a2563b3f914c35a018b7a2b">BET</dd>
</dl>
<p ><strong>Netflix description: </strong>Ambitious single TV  journalist Mary Jane attempts to balance her career with her  overbearing family and an increasingly messy love life.</p>
<p ><strong>Critic score:</strong> 78%</p>
<p ><strong>Audience score:</strong> 75%</p>
<p >  Gabrielle Union does some of her best work both dramatically and  comedically on this charming series from BET. The show accurately  and beautifully represents a modern and independent career woman  in a way that defies the cliche. It&#8217;s already been canceled, but  the story will end with a movie set to air later this year. </p>
<hr />
<h3 >&#8220;Jane the Virgin&#8221; &mdash; The CW, four seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/5afd9c931ae66236008b46b1.jpg" id="image-5afd9c931ae66236008b46b1" class="bi_image size-medium wp-image-1051555" bisrc="https://static.businessinsider.com/image/5afd9c931ae66236008b46b1.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5afd9c931ae66236008b46b1">The CW</dd>
</dl>
<p ><strong>Netflix description: </strong>After vowing to remain  chaste until marriage, Jane Villanueva learns she&#8217;s pregnant due  to a medical slip-up and has to rethink her future.</p>
<p ><strong>Critic score:</strong> 100%</p>
<p ><strong>Audience score:</strong> 88%</p>
<p >  Like the ABC dramedy &#8220;Ugly Betty,&#8221; &#8220;Jane the Virgin&#8221; both  embraces and satirizes the telenovela and in this particular  case, romance. This show will make you roar with uncontrollable  laughter, but thirty seconds later you&#8217;ll sob &#8211; and then you&#8217;ll  immediately go back to laughing. It&#8217;s gotten even more ambitious  with the storylines it&#8217;s covered throughout the seasons,  including grief, cancer, and having your baby kidnapped by a  notorious drug lord and murderer. </p>
<p >  Expect season five of &#8220;Jane the Virgin&#8221; (its final season) in the  fall. </p>
<hr />
<h3 >&#8220;Better Call Saul&#8221; &mdash; AMC, three seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/53c3fd2669bedd9169d1a0a5.jpg" id="image-53c3fd2669bedd9169d1a0a5" class="bi_image size-medium wp-image-1051554" bisrc="https://static.businessinsider.com/image/53c3fd2669bedd9169d1a0a5.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-53c3fd2669bedd9169d1a0a5">Ursula Coyote/AMC</dd>
</dl>
<p ><strong>Netflix description: </strong>This Emmy-nominated prequel  to &#8220;Breaking Bad&#8221; follows small-time attorney Jimmy McGill as he  transforms into morally challenged lawyer Saul Goodman.</p>
<p ><strong>Critic score:</strong> 97%</p>
<p ><strong>Audience score:</strong> 93%</p>
<p >  Quite different from the show that it&#8217;s based on (&#8220;Breaking  Bad&#8221;), &#8220;Better Call Saul&#8221; is a quirky character study and not at  all a comedy like many expected it to be, considering Saul  Goodman provided comedic relief on &#8220;Breaking Bad.&#8221; The show dives  so deep into this character that you empathize with him, and goes  just far enough into the world of &#8220;Breaking Bad&#8221; to make sense,  but not so far that it feels desperate. </p>
<p >  Season four premieres on Monday, August 6. </p>
<hr />
<h3 >&#8220;Schitt&#8217;s Creek&#8221; &mdash; CBC, three seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/5a8ee40c42e1cc729d6c4d7c.jpg" id="image-5a8ee40c42e1cc729d6c4d7c" class="bi_image size-medium wp-image-1051553" bisrc="https://static.businessinsider.com/image/5a8ee40c42e1cc729d6c4d7c.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5a8ee40c42e1cc729d6c4d7c">CBS Television</dd>
</dl>
<p ><strong>Netflix description: </strong>Suddenly broke, the  formerly filthy-rich Rose family is reduced to living in a  ramshackle motel in a town they once bought as a joke: Schitt&#8217;s  Creek.</p>
<p ><strong>Critic score:</strong> 61% </p>
<p ><strong>Audience score:</strong> 93%</p>
<p >  The cast of this show is what makes it so good. Comedic geniuses  Catherine O&#8217;Hara and Eugene Levy lead this strange but sometimes  sweet (and brilliantly written) comedy about greedy rich people  who have to adjust to a completely new lifestyle. </p>
<p >  Season four should be available on Netflix in October. It was  renewed for a fifth season, but there&#8217;s not a release date yet,  though it will likely be early 2019. </p>
<hr />
<h3 >&#8220;The Great British Baking Show&#8221; &mdash; BBC, four seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/5410889469bedd4c47c92c22.png" id="image-5410889469bedd4c47c92c22" class="bi_image size-medium wp-image-1051552" bisrc="https://static.businessinsider.com/image/5410889469bedd4c47c92c22.png"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5410889469bedd4c47c92c22">BBC</dd>
</dl>
<p ><strong>Netflix description: </strong>A talented batch of amateur  bakers face off in a 10-week competition, whipping up their best  dishes in the hopes of being named the U.K.&#8217;s best.</p>
<p ><strong>Critic score:</strong> N/A</p>
<p ><strong>Audience score:</strong> N/A</p>
<p >  Somehow, this reality competition show is as soothing as it is  riveting. It&#8217;s a good show to watch while you&#8217;re doing other  things around your house or apartment, but don&#8217;t be surprised if  you find yourself unable to look away. British baking is intense,  and you&#8217;ll find out that your definition of things like bread and  cake have been completely incorrect for your entire life.</p>
<p >  A few more seasons are in the works, but without release dates.  Season five should be available on Netflix later this year. </p>
<hr />
<h3 >&#8220;Black Lightning&#8221; &mdash; The CW, one season available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2017/12/12/5a3bd77db0bcd51c1a8b6470.png" id="image-5a3bd77db0bcd51c1a8b6470" class="bi_image size-medium wp-image-473833" bisrc="https://static.businessinsider.com/image/5a3bd77db0bcd51c1a8b6470.png"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5a3bd77db0bcd51c1a8b6470">The CW</dd>
</dl>
<p ><strong>Netflix description: </strong>School principal and  retired superhero Jefferson Pierce leaps back into action as the  legendary Black Lightning after a gang threatens his family.</p>
<p ><strong>Critic score:</strong> 97%</p>
<p ><strong>Audience score:</strong> 54%</p>
<p >  &#8220;Black Lightning&#8221; brings a new kind of character to the TV  superhero world. Black Lighting is a bit older, and the issues  and villains he&#8217;s facing feel more real and have a more lasting  and powerful impact than shows like &#8220;Supergirl&#8221; or &#8220;Arrow.&#8221;</p>
<p >  Expect season two of &#8220;Black Lightning&#8221; to premiere in the fall. </p>
<hr />
<h3 >&#8220;Documentary Now!&#8221; &mdash; IFC, two seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/580f68e6b28a644d008b48ea.jpg" id="image-580f68e6b28a644d008b48ea" class="bi_image size-medium wp-image-1051551" bisrc="https://static.businessinsider.com/image/580f68e6b28a644d008b48ea.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-580f68e6b28a644d008b48ea">IFC</dd>
</dl>
<p ><strong>Netflix description: </strong>Elevating the art of  parody, this sharply comic series spoofs high-profile  documentaries such as &#8220;Grey Gardens&#8221; and &#8220;The Thin Blue Line.&#8221;</p>
<p ><strong>Critic score:</strong> 94%</p>
<p ><strong>Audience score:</strong> 90%</p>
<p >  As documentaries get more and more popular in the age of  streaming, &#8220;Documentary Now!&#8221; gets funnier and funnier.  Brilliantly written and acted by Fred Armisen and Bill Hader,  this show satirizes iconic documentaries from &#8220;Grey Gardens&#8221; to  &#8220;Vice.&#8221;</p>
<p >  Season three doesn&#8217;t have a release date yet, but it will  premiere in 2019. </p>
<hr />
<h3 >&#8220;How to Get Away with Murder&#8221; &mdash; ABC, four seasons available on Netflix</h3>
<p>      <img  src="https://static.businessinsider.sg/2018/06/06/5ad777870b0b9235008b4784.jpg" id="image-5ad777870b0b9235008b4784" class=" bi_image size-medium wp-image-1051550" bisrc="https://static.businessinsider.com/image/5ad777870b0b9235008b4784.jpg"/>      </p>
<dl  type="image">
<dt class="image-source-label" id="image-source">source</dt>
<dd class="image-source-value" id="image-source-5ad777870b0b9235008b4784">ABC</dd>
</dl>
<p ><strong>Netflix description: </strong>Brilliant criminal defense  attorney and law professor Annalise Keating, plus five of her  students, become involved in a twisted murder case.</p>
<p ><strong>Critic score:</strong> 92%</p>
<p ><strong>Audience score:</strong> 85%</p>
<p >  This show isn&#8217;t super original: there are countless TV shows  about lawyers. But Viola Davis makes this show worth it. She&#8217;s  one of the best actresses alive, and really gives her all for  this fun, sometimes silly show from Shonda Rhimes. It throws  shocking twists and cliffhangers every week, while maintaining an  interesting narrative that&#8217;ll have you binge-watching the entire  series in less time than you thought possible. </p>
<p >  Expect season five of &#8220;How to Get Away with Murder&#8221; to premiere  this fall.  </p>
</p></div></div>
<div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="/tag/features/">Features</a></li> <li><a href="/tag/netflix/">Netflix</a></li> <li><a href="/tag/tv/">TV</a></li></ul></div><div class="addthis_inline_share_toolbox" data-url="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/"></div><div class="OUTBRAIN" data-src="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/" data-widget-id="AR_1" data-ob-template="BusinessInsiderSingapore_1"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

                                    <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.businessinsider.sg/author/businessinsider/"><a target='_blank' href='http://www.businessinsider.com/author/carrie-wittmer/?IR=T'>Carrie Wittmer</a>, <a target='_blank' href='http://www.businessinsider.com/?IR=T'>Business Insider US</a></a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="&lt;a target=&#039;_blank&#039; href=&#039;http://www.businessinsider.com/author/carrie-wittmer/?IR=T&#039;&gt;Carrie Wittmer&lt;/a&gt;, &lt;a target=&#039;_blank&#039; href=&#039;http://www.businessinsider.com/?IR=T&#039;&gt;Business Insider US&lt;/a&gt;"></span><meta itemprop="datePublished" content="2018-06-05T18:24:01+00:00"><meta itemprop="dateModified" content="2018-06-05T18:24:01+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""></span><meta itemprop="name" content="Business Insider Singapore"></span><meta itemprop="headline " content="12 of the best current TV shows you can catch up to on Netflix"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://static.businessinsider.sg/sites/2/2018/06/5b16b73a1ae6621a008b48f2.png"><meta itemprop="width" content="697"><meta itemprop="height" content="523"></span>        </footer>

    </article> <!-- /.post -->

    
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="td_block_template_12 widget widget_text">			<div class="textwidget"><p><div align="center" class="iframeholder">
<!-- /5908/BI_SG/imu2/bi/sg -->
<div id='dfp-ad-imu2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('dfp-ad-imu2'); });
</script>
</div>
</div></p>
</div>
		</aside><aside class="td_block_template_12 widget widget_text"><h4 class="td-block-title"><span>Popular Articles</span></h4>			<div class="textwidget"><p> 
<!-- WordPress Popular Posts Plugin v4.0.0 [PHP] [daily] [views] [custom] -->

<ul class="wpp-list">
<li><a href="https://www.businessinsider.sg/ios-12-changes-updates-new-features-apple-wwdc-2018-6/" title="Apple just announced iOS 12. Here are all the major changes coming to iPhones and iPads." target="_self"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/1049207-featured-100x70.png" width="100" height="70" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.businessinsider.sg/ios-12-changes-updates-new-features-apple-wwdc-2018-6/"><a href="https://www.businessinsider.sg/ios-12-changes-updates-new-features-apple-wwdc-2018-6/" title="Apple just announced iOS 12. Here are all the major changes coming to iPhones and iPads." class="wpp-post-title" target="_self">Apple just announced iOS 12. Here are all the major changes coming to iPhones and iPads.</a></a><p> </p></li>
<li><a href="https://www.businessinsider.sg/mentally-strong-people-2015-11/" title="13 things mentally strong people don&#8217;t do" target="_self"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/55984-featured-100x70.jpg" width="100" height="70" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.businessinsider.sg/mentally-strong-people-2015-11/"><a href="https://www.businessinsider.sg/mentally-strong-people-2015-11/" title="13 things mentally strong people don&#8217;t do" class="wpp-post-title" target="_self">13 things mentally strong people don&#8217;t do</a></a><p> </p></li>
<li><a href="https://www.businessinsider.sg/lebron-james-pass-nba-finals-2018-6/" title="LeBron James threw an underappreciated all-world pass, and it sums up the Cavs&#8217; bleak outlook in the Finals" target="_self"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/1045776-featured-100x70.jpg" width="100" height="70" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.businessinsider.sg/lebron-james-pass-nba-finals-2018-6/"><a href="https://www.businessinsider.sg/lebron-james-pass-nba-finals-2018-6/" title="LeBron James threw an underappreciated all-world pass, and it sums up the Cavs&#8217; bleak outlook in the Finals" class="wpp-post-title" target="_self">LeBron James threw an underappreciated all-world pass, and it sums up the Cavs&#8217; bleak outlook in the Finals</a></a><p> </p></li>
<li><a href="https://www.businessinsider.sg/death-of-the-smartphone-and-what-comes-after-2017-3/" title="The smartphone is eventually going to die, and then things are going to get really crazy" target="_self"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/286274-featured-100x70.jpg" width="100" height="70" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.businessinsider.sg/death-of-the-smartphone-and-what-comes-after-2017-3/"><a href="https://www.businessinsider.sg/death-of-the-smartphone-and-what-comes-after-2017-3/" title="The smartphone is eventually going to die, and then things are going to get really crazy" class="wpp-post-title" target="_self">The smartphone is eventually going to die, and then things are going to get really crazy</a></a><p> </p></li>
<li><a href="https://www.businessinsider.sg/asus-rog-phone-price-release-date-specs-features-2018-6/" title="This crazy new phone has more power than any other Android phone you can buy and comes with a fan to keep it cool" target="_self"><img src="https://static.businessinsider.sg/sites/2/wordpress-popular-posts/1046826-featured-100x70.png" width="100" height="70" alt="" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.businessinsider.sg/asus-rog-phone-price-release-date-specs-features-2018-6/"><a href="https://www.businessinsider.sg/asus-rog-phone-price-release-date-specs-features-2018-6/" title="This crazy new phone has more power than any other Android phone you can buy and comes with a fan to keep it cool" class="wpp-post-title" target="_self">This crazy new phone has more power than any other Android phone you can buy and comes with a fan to keep it cool</a></a><p> </p></li>

</ul>

<!-- End WordPress Popular Posts Plugin v4.0.0 -->
</p>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div class="td-footer-wrapper td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">
            <div class="td-pb-span12">
                <footer id="footer-test">
                    <section class="top">
                    <div class="top-row">
                        <a href="/" class="bi-sg-logo logo"></a>
                        <section class="social-icons">
                            <span class="social-prompt">Follow us on:</span>
							<ul class="links-user">							                                                                    
							    <li class="social">
							        <a href="//www.facebook.com/businessinsider" title="Like us on Facebook" aria-label="Like us on Facebook" target="_blank">
							        <i class="fa fa-facebook" aria-hidden="true"></i></a>
							    </li>

							    <li class="social">
							        <a href="//twitter.com/businessinsider" title="Follow us on Twitter" aria-label="Follow us on Twitter" target="_blank"><i class="fa fa-twitter ks-header-twitter"></i></a>
							    </li>

							    <li class="social">
							        <a href="//www.linkedin.com/company-beta/13353323/" title="Connect with us on LinkedIn" aria-label="Connect with us on LinkedIn" target="_blank"><i class="fa fa-linkedin ks-header-linkedin"></i></a>
							    </li>   
                        	</ul>
						</section>
                        </div>
                        <div class="sister-sites-container">
                            <span class="sister-site-prompt">Also check out:</span>
                            <a href="//www.thisisinsider.com" class="sister-sites sister-one"></a>
                            <a href="//markets.businessinsider.com" class="sister-sites sister-two"></a>
                        </div>

                    </section>

                    <div class="list-pipes">
                        <ul>
                        <li>* Copyright © 2017 Business Insider Inc. All rights reserved. <span class="nowrap">Registration on or use of this site constitutes acceptance of our <a href="http://sph.com.sg/legal/website_tnc.html">Terms of Service</a> and <a href="http://sph.com.sg/legal/pdpa.html">Privacy Policy</a>.</span>
                        </li>
                        <li><a href="//www.businessinsider.sg/advertise-with-business-insider-singapore/">Advertise with us</a></li>
                    </ul>
                    </div>
					<div class="list-pipes">
                        <ul>
                        <li>SPH Digital | Business Insider</li>
                        </ul>
                    </div>
                    <div class="international-links list-pipes">
                        <ul><li>International Editions:</li>
                            <li><a href="http://www.businessinsider.com?IR=C">US</a></li>
                            <li><a href="http://uk.businessinsider.com?IR=C">UK</a></li>
                            <li><a href="http://www.businessinsider.de?IR=C">DE</a></li>
                            <li><a href="http://www.businessinsider.com.au/">AUS</a></li>
                            <li><a href="http://www.businessinsider.in/">IN</a></li>
                            <li><a href="http://www.businessinsider.my/">MY</a></li>
                            <li><a href="https://www.businessinsider.sg/">SG</a></li>
                            <li><a href="http://www.businessinsider.com.pl/?IR=C">PL</a></li>
                            <li><a href="http://nordic.businessinsider.com/?IR=C">SE</a></li>
                            <li><a href="http://www.businessinsider.nl?IR=C">NL</a></li>
                            <li><a href="http://www.businessinsider.fr/?IR=C">FR</a></li>
                            <li><a href="https://it.businessinsider.com">IT</a></li>
                            <li><a href="http://www.businessinsider.jp">JP</a></li>       
							<li><a href="https://www.businessinsider.es">España</a></li>
							<li><a href="https://www.businessinsider.co.za">South Africa</a></li>
                        </ul>
                    </div>
</footer><aside class="td_block_template_12 widget widget_text">			<div class="textwidget"><p></p>
</div>
		</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
</div><!--close td-outer-wrap-->


		<script type="text/javascript">
		<!--
		xtnv = document;         //parent.document or top.document or document         
		xtsd = "//logw348";
		xtsite = "585986";
		xtn2 = "7";        //level 2 site 
		xtpage = "business-insider-singapore::life::12-of-the-best-current-tv-shows-you-can-catch-up-to-on-netflix";    //page name (with the use of :: to create chapters)
		xtdi = "";        //implication degree
		xtdmc = ".businessinsider.sg";
		xt_multc = "&x1=12-of-the-best-current-tv-shows-you-can-catch-up-to-on-netflix&x2=https://www.businessinsider.sg/best-current-tv-shows-on-netflix-riverdale-better-call-saul-the-good-place-2018-6/&x3=life,tech-insider&x4=features,netflix,tv";//all the xi indicators (like "&x1=...&x2=....&x3=...") - self custom
		xt_an = ""; //user ID - self custom
		xt_ac = ""; //category ID - self custom
		//do not modify below - self custom
		if (window.xtparam!=null){window.xtparam+="&ac="+xt_ac+"&an="+xt_an+xt_multc;}
		else{window.xtparam="&ac="+xt_ac+"&an="+xt_an+xt_multc;};
		//-->
		</script>
	<script type="text/javascript" src="https://www.businessinsider.sg/wp-content/plugins/at-internet-analyzer-nx/js/xtcore.js"></script>
		<noscript>
		<img width="1" height="1" alt="" src="//logw348.ati-host.net/hit.xiti?s=585986&s2=7&p=business-insider-singapore::life::12-of-the-best-current-tv-shows-you-can-catch-up-to-on-netflix&x3=life,tech-insider&x4=" >
		</noscript><!-- Go to www.addthis.com/dashboard to customize your tools --> 
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-592298eef9dcb78d"></script>

<style>
.addthis_inline_share_toolbox{
    text-align:center;
}
.at-share-btn-elements{
    display: flex;
    justify-content: space-between;
}
.at-share-btn{
    width:20%;
}
</style><!-- /5908/BI_SG/topoverlay/bi/sg -->
<div id='dfp-ad-topoverlay'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('dfp-ad-topoverlay'); });
</script>
</div><!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6288331" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="//b.scorecardresearch.com/p?c1=2&c2=6288331&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 7.8 (rara)
        Deploy mode: deploy
        
        uid: 5b16e59902a9e
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">

/* custom responsive css from theme panel (Advanced CSS) */
@media (min-width: 768px) and (max-width: 1018px) {
.td-ss-main-content > div:nth-child(3) {
    margin-top: 30px;
}
}
</style>

 
<script> jQuery(document).ready( function() { var gggtm = '<!-- Google Tag Manager --><noscr'+'ipt><iframe src="//www.googletagmanager.com/ns.html?id=GTM-NX4342R" height="0" width="0" style="display:none;visibility:hidden"></iframe></nosc'+'ript><!-- End Google Tag Manager --><!-- Google Tag Manager US --><noscr'+'ipt><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MTGK9G" height="0" width="0" style="display:none;visibility:hidden"></iframe></nosc'+'ript><!-- End Google Tag Manager US-->'; jQuery('body').prepend(gggtm); }); </script> 
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/plugins/businessinsider-td-api-plugin/js/script.js?ver=4.8.6'></script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/plugins/businessinsider-td-api-plugin/js/picturefill.js?ver=4.8.6'></script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=7.8'></script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-includes/js/comment-reply.min.js?ver=4.8.6'></script>
<script type='text/javascript' src='//maps.googleapis.com/maps/api/js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ubermenu_data = {"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"767","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","collapse_after_scroll":"on","v":"3.2.7","configurations":["main"],"ajax_url":"https:\/\/www.businessinsider.sg\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/www.businessinsider.sg\/wp-content\/plugins\/ubermenu\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.businessinsider.sg/wp-content/plugins/ubermenu/assets/js/ubermenu.min.js?ver=3.2.7'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.businessinsider.sg/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.businessinsider.sg/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>